This project is read-only.

cloning a repo: Basic credentials are only supported over HTTPS

Dec 4, 2012 at 5:23 PM

I'm trying to connect to a tfs server on a LAN.

I'm currently using tfs eclipse plugin successfully. I'd love to work with a local git repo so I'm trying to use git-tf.

The installation process was easy and painless, but when I try to clone i have the following error 

git tf clone http://<server-ip>:8080/tfs/DefaultCollection $/OMP/DEV/OMP\ 1.10.x 

Username: <domain>\<username>


Connecting to TFS...

git-tf: Basic credentials are only supported over HTTPS secured connections.

I tried to use the same ip and port with https but it didn't work with this error: [git-tf: Unrecognized SSL message, plaintext connection?].

I also tried (almost) any permutation of projectcollection addresses and serverpath (example: http://<server-ip>:8080/tfs ; $/). 

What am I doing wrong? 


My system is:

linux Xubuntu 12.10

git version:

git-tf version

Dec 10, 2012 at 5:12 PM


Sorry for the late reply here, This is a known bug in Git tf with basic auth. The problem is that you have a tf proxy set which git tf does not work well with over basic auth. To fix this issue you can run :

tf proxy /enable:false

to turn off the proxy.