git-tf: The item $/TeamName was not found in the repository at the specified version T

Mar 5, 2013 at 5:14 PM
Edited Mar 5, 2013 at 5:15 PM
Hi,

I try to clone from a visualstudio.com TFS location, but I receive the error:

"git-tf: The item $/TeamName was not found in the repository at the specified version T"

The command I use is:

git tf clone https://oop.visualstudio.com/DefaultCollection $/TeamName

which nicely asks for my username and password. I provide them and the script continues (I've enabled the basic authentication).

I receive mostly the same error when i tried the following alternatives. A few exceptions depicting that the collection was not found.


The alternatives I tried:
Debugging is kind of hard as I don't know what the actual error means.

Anyone who can hint on this?

Kind regards,

Mark

Ps. I use git-tf version 2.0.2.20130214 on a Debian machine (6.0) running 2.6.32-5-amd64 kernel
Developer
Mar 5, 2013 at 5:19 PM
Edited Mar 5, 2013 at 5:19 PM
The syntax you want is definitely:
git tf clone https://yourname.visualstudio.com/DefaultCollection $/Full/Path/to/Your/Project
Any version with _git in the URL is used for git repositories, not Team Foundation Version Control.

The error message you quote indicates that the path $/TeamName does not exist. (The error message is a bit confusing - T in this case stands for "tip", or the "latest version" in Team Foundation Version Control.)

If you navigate to $/TeamName in Team Explorer on on the web, are you able to see it?
Mar 5, 2013 at 5:30 PM
Thanks for your swift reply!

Okay, so if I understand correctly;

When my URL is:

https://XXX.visualstudio.com/DefaultCollection/_git/ProjectName#path=%2F&version=GBmaster&_a=contents

(in which I do see a folder containing the subsequent folders and code)

I should use:

git tf clone https://XXX.visualstudio.com/DefaultCollection $/


And if my URL would be:

https://XXX.visualstudio.com/DefaultCollection/_git/ProjectName#path=%2Fdomains%2Fdomain.com&version=GBmaster&_a=contents

it should be:

git tf clone https://XXX.visualstudio.com/DefaultCollection $/domains/domain.com

Right?

In both cases the error remains the same though :'(

I can't help but think I have to specify the "ProjectName" (or teamname?) somewhere in the clone command, though I don't know where.
Developer
Mar 5, 2013 at 5:33 PM
Hello MarkPrins,

If your project on TFS service is a git project not a TFVC project you should use git tools (git clone) and not git tf clone. git tf is for exposing TFVC projects as git repositories.

Thanks,
Youhana
Developer
Mar 5, 2013 at 5:33 PM
It looks like your code is in an actual git repository? (You selected "New Team Project + git" when you created this team project?)

If that's the case, you should not be using git-tf at all -- git-tf is intended only to create a local git repository that maps to a remote (centralized) Team Foundation Version Control repository.

Instead, you can simply clone using git itself:
git clone https://XXX.visualstudio.com/DefaultCollection/_git/ProjectName
Mar 5, 2013 at 5:39 PM
Doh, yes indeed!

The problem is (or was), the repo is managed by someone else. I (mis)asumed it was a TFS server.

At first I ran across the not enabled (basic) authentication problem, and couldn't find out why it wasn't working.

Subsequently I (mis)asumed that it then probably would be a TFS host and came across git-tf.

Only then I realised the basic auth should be enabled. And at that time I never considered that visualstudio.com supported both GIT and TFS.

Thank you kindly for your time and forgive me for my ignorance.
Developer
Mar 5, 2013 at 7:08 PM
Indeed - git is a very new addition to Team Foundation Service and it's easy to overlook. Further, because it's so new and because we're rapidly adding features here, some things are not quite as elegant as they could be.

git-tf should probably provide a more informative error here. It's sort of dense - as you noticed - even in the case when you're using Team Foundation Version Control and the item doesn't exist. We could do a lot better here when you point it at a git repository.

Glad everything's working!

Thanks-
-ed
Mar 20, 2013 at 6:13 PM
Edited Mar 20, 2013 at 6:14 PM
Good Afternoon,

I am experiencing an error similar to Mark's error above. I have a TFS Server and on that server I have created a new project "$/Websites/User Interface". At the moment the project is empty (save for the "BuildProcess Templates" directory which is created by default).

I'm using the following command line script to attempt to clone the project ...
git tf clone https://tfs:8080/tfs "$/Websites/User Interface"
and I receive the following error when I execute the command ....
Cloning $/Websites/User Interface into C:\test\User Interface: 0%
git-tf: The item $/Websites/User Interface was not found in the repository at the specified version T
The repository on TFS is NOT a git repository. The project was created on TFS directly.

I'm not sure if I am experiencing the same error as Mark was but I'm not sure what I'm doing wrong.

Thank you,
Scott
Developer
Mar 20, 2013 at 6:16 PM
Can you post a screenshot of navigating to this directory in Web Access?
Developer
Mar 20, 2013 at 6:28 PM
Hi Vercuski,

I believe you've missed the Team Project Collection name in your server URL. Presuming that your collection has the default name "DefaultCollection" you should use the command:
git tf clone https://tfs:8080/tfs/DefaultCollection "$/Websites/User Interface"
One more note, it looks like your TFS server is not in the cloud. As I can see, you use the port number 8080. Are you sure you should use HTTPS but not HTTP protocol?

Alex
Mar 21, 2013 at 12:33 PM
Hi Alex,

I just tried adding "DefaultCollection" to the url as you suggested and I get the same result.

You are correct. My TFS server is not in the cloud. We're not currently using https. If I switch the URL to use https I receive the following git tf message ...
git-tf: Unrecognized SSL message, plaintext connection?
if I put the url http://tfs:8080/tfs/ into a browser it comes back fine with the sharepoint site ... if I use http://tfs:8080/tfs/DefaultCollection the link does not work.

Thank you for your help ! It is much appreciated.
Scott Vercuski
Developer
Mar 21, 2013 at 1:41 PM
Hi Scott,

The "DefaultCollection" name was just an example. Based on what you've explained I could guess that your server does not have a collection named "DefaultCollection". Could you check which collections does your server contain, and which one your project belongs to?

E.g.
  1. In te Internet Explorer enter the url of your TFS server (http://tfs:8080/tfs/).
  2. In the left column you should see the "Recent Projects and Teams" list.
  3. Underneath the list you should see the "Browse all..." button.
  4. Click the button and the "Browse Server" window should pop up.
In the window you may see a list with collections and included projects. Find your project and its parent collection. The name of this collection you should use un the URL instead of "DefaultCollection".

Gegards,
Alex
Mar 21, 2013 at 3:24 PM
Alex,

Thank you ! that did the trick !!! I got it to work !!

Thanks again,
Scott
Developer
Mar 21, 2013 at 4:29 PM
Hi Scott,

I'm glad to hear that. Let us know if you need more assitance.

Alex