This project is read-only.

clone Visual Studio online

Nov 2, 2014 at 9:49 AM

i am using VS online and trying to move to GIT on premise.
I tried this:
git-tf clone $/yyyy/zzzz --deep

Then prompt for password 3 times or so and in the end get:
git-tf: Access denied connecting to TFS server
aultCollection. You either provided a wrong password or basic authentication is
not configured for your account

In the home page, this project is said to work with VS Online. Any clue ?
Nov 3, 2014 at 3:55 PM

Have you defined alternative credentials for you VSO account?

Nov 3, 2014 at 4:37 PM

Not sure what you mean. I log on VSO with my Microsoft Account (Live ID). So it's not using a basic http authentication
Nov 4, 2014 at 2:50 PM

Please see "Basic auth support" chapter in the article . Regardless that it does not say that explicitly, I would also recommend you to enter the secondary user name and use it in Git-TF connecting to your account. (Not all Git related tools correctly handle user names with the "@" character in them.)

Nov 4, 2014 at 7:05 PM
Sorry, i wasn't aware of that option.
Now it works great :)