Git-TF : Connecting to VSO-TFVC

Mar 3, 2015 at 6:14 AM
Edited Mar 3, 2015 at 6:14 AM
I use the following command to clone
Git-tf clone https://xxx.visualstudio.com/DefaultCollection $/xxx/Main --deep

However, when I provide the user name and password, I get the below error:
Access denied connecting to TFS server https://xxx.visualstudio.com/DefaultCollection. You either provided a wrong password or basic authentication is not configured for your account.

I am part of the Project Administrators. I tried creating an alternate account, but when I use the alternate account, I get the below error :
git-tf: Basic credentials are only supported over HTTPS secured connections.

Any pointers to overcome the above problem will be helpful.
Developer
Mar 4, 2015 at 6:35 PM
Hi,

When you enabled alternate credentials, did you specify both the password and the secondary user name? I would recommend to do that.

Do you have a proxy set up in your environment? Try to disable it.

Which operating system do you use?

What version of Git-TF do you have (tip: gi-tf --version)

Alex
Marked as answer by kothair on 3/18/2015 at 9:26 PM
Mar 18, 2015 at 12:03 PM
Edited Mar 18, 2015 at 12:27 PM
  1. Specified both secondary user name and password.
  2. How do I do this ? (where do I run 'tf proxy /enable:false' ?)
  3. Windows 8.1
  4. git-tf version 2.0.3.20131219
Developer
Mar 18, 2015 at 3:24 PM
Hi,

According another topic (cloning a repo: Basic credentials are only supported over HTTPS) it looks like you do have tf proxy installed. That means you have Visual Studio installed. Run the command from VS developer command prompt window.

Alex
Mar 19, 2015 at 5:14 AM
The problem is resolved. This is what I did :

Visual Studio -> Tools -> Options -> Source Control -> Visual Studio Team Foundation Server -> uncheck "Use Proxy Server for file downloads".

Now use Git-tf Clone, it works !
Developer
Mar 19, 2015 at 5:19 PM

Hi,

I’m glad to hear that!

Alex