This project is read-only.

Some Changes could not be pended

Dec 8, 2016 at 10:16 AM
Im trying to do a migration from SVn to TFS with full message history. I have created a Git Repo which is fine and contains everything i need but am unable to push this to TFS.

i have configured git tf

git tf configure <Server>/tfs/Projects '$\TestProject\Main' --force

I have created the user map file (based on the generated template)

Then i have done the preview

git tf checkin --deep --ignore-author --preview and that completes with the message "Done".

However when i run the command

git tf checkin --deep --ignore-author i get the error message:
git-tf: Some changes could not be pended

I have checked to ensure the file path length is not greater than 259 characters and they aren't (max 255 chars)

Has anyone got any ideas?
Feb 23, 2017 at 1:39 PM

I have same problem. git-tf checkin --preview command result is Done but when I run the command without --preview parameter, the result is git-tf: Some changes could not be pended.

I need help also.

Apr 10, 2017 at 6:49 AM
Im my case the problem was a too long file path. As i moved the whole repository to "c:\r" the checkin works