This project is read-only.

Source control bindings - mixed TFS and Git-Tf team

Aug 29, 2012 at 9:16 PM

When I open a project checked out by git-tf I get:

"The associated source control plug-in is not installed or could not be initialized...
- Temporarily work uncontrolled
- Permanently remove source control association bindings"

I've been answering "Temporarily work uncontrolled". This is pain to answer for each project each time it changes. If we answer "Permanently remove..." this appears to remove binding info from the .sln an .csprojs which I am worried will impact other developers working with straight TFS.

Any suggestions / recommendations? Can I tell Visual Studio to permanently ignore bindings on a single folder just for me?


Aug 29, 2012 at 9:27 PM

Hello Brian,

we surely need to do better here, git-tf should ultimately be able to update the binding somehow to disable the VS TFSProvider to try and bind the solution to tfs. The best way to work around this is to work offline. When you open the solution VS after cloning it using git-tf you should get the following prompt

Microsoft Visual Studio
Team Foundation Server Version Control

The solution you are opening is bound to source control on the following Team Foundation Server: [SERVER URI] Would you like to contact this server to try to enable source control integration?
Yes   No   Help  

The answer should be NO. That will mark your solution as offline.

That said, may I know the Visual Studio version you are using. The scenario above will work for VS 2012. If you are working with older VS Clients the experience might be different though.



Aug 29, 2012 at 10:40 PM

VS2010 SP1, TFS 2008, Win7 64 bit

I tried a fresh clone and receive:

"The solution appears to be under source control, but its binding information cannot be found. Because it is not possible to recover this missing information automatically, the projects whose bindings are missing will be treated as not under source control."

click ok, then I get:

"The assoicated source control plug-in is not installed or could not be initialized. Common causes for this error include server unavailablility and/or incorrect workspace mappings." and I can choose from two options:
- Temporarily work uncontrolled
- Permanently remove source control association bindings

I also tried using the GoOffline extension but that appears to remove the binding information.


Sep 13, 2012 at 9:03 PM

Hello Brian,

Sorry for the delayed reply here. Our experience in VS 2012 is way better than VS 2010 when it comes to offline SLN handling. That said, I apologize, I have not investigated this issue yet with Dev10. I will repro it locally and reply back with my findings.



Sep 17, 2012 at 10:26 PM

Thanks Youhana. This is just an inconvenience. I am willing to click a few extra times to use git.

A bit more important, we are finding that if we change the solution (e.g. adding an item in a Solution Folder) the source control information is removed from the .sln.

Oct 4, 2012 at 8:55 PM

Hello Brian,

Sorry for the delayed reply here. We added a couple of items on our backlog to address solution bindings for git-tf. Sorry for the inconvience.

Please let us know if hit any other issues or have any feedback or suggestions.



Oct 11, 2012 at 12:17 AM

Thanks. We are really happy with git-tf. Keep up the good work. Looking forward to the next release.


Jul 23, 2013 at 5:45 PM
Jul 25, 2013 at 11:38 PM
Another coworker suppressed the dialog by:
  1. Add workspace mapping in TFS to map the source to your local git folder
  2. Disconnect your network connection
  3. Open the solution
  4. Use the Offline VS extension to offline the solution
  5. Close everything and re-plug in your network connection