Error while trying to checkin for the first time

Apr 16, 2013 at 8:12 AM
I'm trying to checkin for the first time to TFS using "git tf checkin --deep". It reaches 55% but stops with the following error: "git-tf: failed to pend changes to TFS due to the following errors. Please fix the errors and retry check in. The item [filename with full path on TFS] already has pending changes.".

How can this be solved? Thanks
Coordinator
Apr 16, 2013 at 3:19 PM
Hi,

Did the checkin fail before due to a different reason then the second time you tried the checkin you got this error? what type of changes did you have?

Thanks
Mireille
Developer
Apr 16, 2013 at 3:24 PM
Hi ionutvasiliu,

Could you please provide some additional information regarding this issue?
  • Which versions of Git-TF and TFS server do you use?
  • You mentioned that you checked in for the first time. Does it mean that the TFS folder you checked into was empty? Or it is not empty and other users could pend changes to it?
  • Could you send us Git-TF logs related to the issue. You could find them in:
Windows: %LOCALAPPDATA%\Microsoft\Team Foundation\4.0\Logs\git-tf-*.log.
Unix: ~/Library/Application Support/Microsoft/Team Foundation/4.0/Logs/git-tf-*.log.

Thanks,
Alex