This project is read-only.

Problem cloning tfs repository "a server path must be absolute"

Apr 30, 2014 at 2:30 PM
I am having trouble cloning a tfs repository. I think I'm using the correct syntax, based on the "getting started" page and some posts I've read on here, but I always get the same error.

My TFS server is: http://psm-tfsdev01:8080/tfs My project collection is: 2008_imported.
My project is: DynamicPayable

I am at the root of my C: drive. My command:

git-tf clone --deep http://psm-tfsdev01:8080/tfs/2008_imported $DynamicPayable I get the following error: git-tf: A server path must be absolute.

It seems there must be something simple I'm missing, but I don't know what. Any ideas?
Apr 30, 2014 at 2:45 PM
Hi Rich,

You're right. That's simple. :-) A misprint probably. The root of the TFS server collection is $/. So the absolute path has to start with these two characters. In your case it should be $/DynamicPayable. If you miss the slash character (/), the path looks like a relative one, i.e. not starting with the collection root $/.

Apr 30, 2014 at 2:47 PM
Yes, that's it. Thanks!
Dec 1, 2015 at 6:22 PM
@arukhlin I'm seeing the same error but I'm pretty sure I specified the path correctly:
git tf clone --deep $/MyProject

git-tf: A server path must be absolute: $C:/Users/John/AppData/Local/GitHub/PortableGit_c7e0cbde92ba565cb218a521411d0e854079a28c/MyProject
Am I missing something?
Dec 1, 2015 at 6:56 PM
Well, I closed and reopened powershell and then it worked ... not sure what happened