This project is read-only.

Solved: "git-tf: Some changes could not be pended"

Jun 3, 2014 at 4:35 PM
I have been trying to migrate a Git repo to a TFS server. It kept failing to complete at 87% with the following error:
git-tf: Some changes could not be pended
I checked the git-tf logs and found nothing that indicated why the checkin had failed.

I used the following steps:
  1. cd C:\...\MyTfsProject
  2. git tf configure http://mytfs:8080/tfs/DefaultCollection $/MyProject
  3. git tf checkin --deep --keep-author --metadata
  4. This generated a USERMAP file, which I modified to correctly map users
  5. git tf checkin --deep --keep-author --metadata
I decided to try using git-tfs instead, since git-tf kept failing. When cloning TFS into a local Git repository with git-tfs, it eventually issued the following error on the same changeset that git-tf did:
TF400889: The following path contains more than the allowed 259 characters: C:\...\filename.txt. Specify a shorter path.
So, I moved the directory to the root of the drive and issued the git tf checkin command again; this time it worked. The maintainers of this project may wish to add additional error checking/handling for long filenames/paths.