Unable to find a required JAR

Sep 8, 2015 at 7:20 PM
Edited Sep 8, 2015 at 7:25 PM
Hi, I'm trying to install git-tf on Windows 8.1. I've tried installing via Chocolatey and by unzipping to C:\git-tf and adding that to my local env variables. No matter what, I get this error anytime I run git tf anything.
Unable to find a required JAR: C:\git-tf/lib/com.microsoft.gittf.client.clc-*.ja
r does not exist
I haven't changed or moved any files associated with git-tf.

I use a Mac at work and git-tf works great on there, but I'm trying to show my Windows-using coworkers how to use git-tf and it's not working. Any help would be appreciated.

Edit: I assume it has something to do with path mixing different slashes. It's looking for a JRE with forward slashes, and obviously Windows uses backslashes.
Sep 14, 2015 at 3:50 PM
Hi Hutchentoot,

I install (unzip) git-tf on my win 7 pro.
I added c:\git-tf to my PATH env variable.
In a DOS console :
git tf produces the same error as yours but git-tf works
Nov 5, 2015 at 2:10 AM
Edited Nov 5, 2015 at 2:38 AM
I think this has something to do with Git. My friends version is 1.9.5 does not encounter the issue above. Mine's on 2.6.2, and I get the error.

UPDATE: edit git-tf and force execution of git-tf.cmd
#case `uname -s` in
#   CYGWIN_NT*)
#       PLATFORM=cygwin
#       ;;
#   MINGW32_NT*)
#       PLATFORM=mingw32
#       ;;
#   *)
#       PLATFORM=unix
#       ;;
#esac

PLATFORM=mingw32
Developer
Nov 5, 2015 at 3:01 PM
Hi,

It looks like the commits d28ef0bd94e9... 207d1b91da4d by Johannes Schindelin on 8/24/2005 fix this issue. You might give that fix a try by downloading and building the latest sources.